Wp-CLI funktioniert nicht mit WordPress installiert mit Composer

Ich habe eine Version von WordPress mit Composer installiert und die Standardordner für den Inhalt (/ wp-content) und den core (/ wp) geändert.

Meine wp-config.php bezieht ihren DB_NAME, DB_USERNAME, DB_PASSWORD von Umgebungsvariablen, die in der .htaccess Datei definiert sind.

Ich kann mit meinem Browser eine Verbindung zu meiner WordPress-Instanz herstellen, sodass die Verbindungsinformationen dort gut sind.

Ich habe es nicht geschafft, wp-cli für diese Instanz auszuführen. wp-cli –debug gibt aus:

Debug (bootstrap): No readable global config found (0.014s) Debug (bootstrap): No project config found (0.016s) Debug (bootstrap): No package autoload found to load. (0.261s) Debug (bootstrap): ABSPATH defined: /path/to/core/ (0.272s) Debug (bootstrap): Begin WordPress load (0.288s) Debug (bootstrap): wp-config.php path: /path/to/wp-config.php (0.292s) Error: Error establishing a database connection 

(Ich habe diese Pfade doppelt überprüft und sie sind korrekt)

Ich bekomme immer denselben Fehler. Ich habe versucht, eine saubere Instanz mit Composer zu installieren, aber dieses Mal:

  • ohne irgendein plugin
  • ohne irgendein Thema
  • indem Sie DB_NAME, DB_USERNAME, DB_PASSWORD direkt in der Datei wp-config.php definieren, anstatt diese von env zu beziehen. Variablen.
  • aber ich habe die benutzerdefinierte Ordnerstruktur / wp für den core und / wp-Inhalt für den Inhalt beibehalten

Immer noch der gleiche Fehler … Vermisse ich etwas? Ist es die benutzerdefinierte Ordnerstruktur, die wp-cli nicht mag?

 Executing wp-cli --info outputs this : PHP binary: /usr/bin/php PHP version: 5.5.36 php.ini used: WP-CLI root dir: phar://wp-cli.phar WP-CLI packages dir: WP-CLI global config: WP-CLI project config: WP-CLI version: 0.24.1 

Ich bin auf Max OS X El Capitan.

Vielen dank für Deine Hilfe,

Julien

Solutions Collecting From Web of "Wp-CLI funktioniert nicht mit WordPress installiert mit Composer"