WordPress Facebook Open Graph Plugin funktioniert nicht für 1 bestimmtes Bild

Ich habe ein wirklich komisches Thema. Ich verwende das Facebook Open Graph, Google+ und Twitter Card Tags Plugin, um offene Graph-Tags für meine WordPress-Seiten zu erstellen. Normalerweise funktioniert das reibungslos. Es nimmt das erste Bild einer Seite und verwendet es als og:image Tag.

Beispielseite: https://ungehorsam.org/programm/geschichten

Das erstellte Tag (siehe HTML-Code der oben verlinkten Seite) sieht folgendermaßen aus:

  

Ich habe jedoch eine seltsame problematische Seite. Die Seite wird nicht geladen: https://ungehorsam.org/programm/empty-cages

Ich habe den HTML-Code inspiziert und es scheint, dass es genau dort anhält, wo die offenen Facebook-Grafik-Tags erscheinen sollen. Es stellt sich heraus, dass wenn ich das Bild aus dem Post entferne, die Seite normal geladen wird. Außerdem: Wenn ich ein anderes Bild als dieses Bild verwende, rendert die Seite wie erwartet. Es scheint, dass nur wenn ich dieses spezifische Bild verwende , die offenen Graph-Tags nicht vom Plugin generiert werden können.

Also habe ich es versucht:

  • verwende ein anderes Bild als dieses => Seite geladen
  • lösche und aktualisiere das problematische Bild => Seite wird immer noch nicht geladen
  • Löschen, speichern Sie das Bild mit etwas anderer Qualität, und laden Sie es neu => Seite wird immer noch nicht geladen

Ich hatte keine Ideen mehr, wie ich das jetzt angehen könnte. Was ist das Problem mit diesem Bild? Warum kann das Plugin keine offenen Grafik-Tags erstellen, wenn dieses Bild im Beitrag enthalten ist?

Solutions Collecting From Web of "WordPress Facebook Open Graph Plugin funktioniert nicht für 1 bestimmtes Bild"

Keine direkte Antwort auf Ihre Frage, aber möglicherweise eine Lösung für Ihr Problem.

Das Herunterladen des gleichen Bildes aus einer anderen Quelle führte wahrscheinlich zu einer genauen Kopie (Hash-weise), da sie wahrscheinlich von der gleichen Quelle stammen wie Sie. Ein wilder Stich in die Dunkelheit hier, aber es ist möglich, dass es etwas über die Bilddaten oder Meta-Daten gibt, die nicht gut spielen. Sie können versuchen, das Problem zu beheben, indem Sie das Bild in Ihrem bevorzugten Editor öffnen und Metadaten im Bild entfernen oder ändern und erneut speichern. Auch wenn keine vorhanden ist, speichern Sie sie trotzdem erneut (möglicherweise mit einer anderen Komprimierungseinstellung, um eine komplett neue Datei zu erzwingen). Sie könnten sogar so weit gehen, um es als neuen Datentyp zu speichern, z. B. png.

Wenn das das Problem triggers, kannst du weitermachen. Wenn nicht, würde ich sagen, dass ich mich mit den Plugin-Entwicklern in Verbindung setzen muss, um zu sehen, was sie darüber zu sagen haben.

Ich würde Ihnen gerne dabei helfen, aber ich benötige weitere Informationen darüber, wie Sie den Post / die Seite erstellt haben, die fehlgeschlagen ist. können Sie Ihre Frage aktualisieren, um den Textcode einzubeziehen, der zum Erstellen der errorshaften Seite oder Post verwendet wurde, damit ich das Problem bearbeiten kann. Eine andere Alternative ist das yoast Plugin zusammen mit dem WPSSO Core Plugin. Diese 2 Plugins werden alle og Daten automatisch sortieren. Wenn Sie es vorziehen, Daten manuell zu machen, dann veröffentlichen Sie bitte Ihren un gerenderten HTML-Code aus dem fraglichen Post / der fraglichen Seite.

Hoffe das hilft.