Wie kann ich die Kompatibilität der WordPress-Website mit der PHP-Version prüfen?

Mein Host aktualisiert die PHP-Version von 5.4 auf 5.6. Ich kann keine https: // Seiten sehen oder wp-admin bei den Test-Sites anmelden, um Probleme zu sehen. Ich habe irgendwo gelesen, dass WordPress PHP 5.6 empfiehlt. ABER, ich weiß nicht, ob die Plugins irgendwelche Probleme haben. Ich kann jedoch feststellen, dass das Fehlerprotokoll keine Fehler enthält. Bedeutet kein PHP-Parsererrors, dass alles kompatibel ist?

Solutions Collecting From Web of "Wie kann ich die Kompatibilität der WordPress-Website mit der PHP-Version prüfen?"

Standardmäßig ist WP sehr zurückhaltend, um Fehler anzuzeigen oder anzuzeigen. Das steht in Einklang mit seiner Strategie, die Dinge zu “verdummen”.

Die Konfiguration, die ich zur wp-config.php in wp-config.php :

 define( 'WP_DEBUG', true ); define( 'WP_DEBUG_DISPLAY', false ); @ini_set( 'display_errors','Off' ); @ini_set( 'log_errors','On' ); @ini_set( 'error_log','/home/user/logs/php_site_name.log' ); 

Es gibt auch WP native WP_DEBUG_LOG Konstante, aber unglücklicherweise haben sie sich dafür entschieden, es WP_DEBUG_LOG zu machen, um in das öffentliche Inhaltsverzeichnis zu schreiben, was eine schlechte Übung ist.

Und ja, eine allgemeine Aktualisierung auf eine neuere Version von PHP führt normalerweise zu Brüchen und Fehlern, wenn etwas inkompatibel ist. Nicht viel anderes zu tun, kurz Code-Überprüfung von allem.