Wie entferne ich die WordPress-Version aus der Browser-Quelle?

Ich möchte die WordPress-Version von meinem Quellcode entfernen. Um dies zu erreichen, habe ich folgenden Code in meine functions.php Datei eingefügt:

function wordpress_remove_version() { return ''; } add_filter('the_generator', 'wordpress_remove_version'); 

Dieser Code hat in der Vergangenheit für mich funktioniert, aber aus irgendeinem Grund erscheint die WordPress-Version immer noch in meinem Quellcode.

Ich habe meine Plugins aber immer noch ohne Erfolg deaktiviert. Es hat auch nicht das Internet nach Updates für neue Codes etc.

Hat jemand anderes dieses Problem oder weiß, wo es schief gehen kann?

Solutions Collecting From Web of "Wie entferne ich die WordPress-Version aus der Browser-Quelle?"

Ihr Code funktioniert für mich in Version 4.7.2 mit Thema 2016, aber eine etwas einfachere Version besteht darin, die Aktion vollständig zu entfernen, anstatt die Ausgabe zu filtern:

 remove_action( 'wp_head', 'wp_generator' ); 

Ich habe das Problem herausgefunden!

Für jeden, der dies liest, funktioniert mein Code einwandfrei. Das Problem liegt in meiner Datei functions.php.

Anstatt folgendes in meiner Datei zu haben:

 function theme_name_script_enqueue() { wp_enqueue_style( 'wpb-fa', get_template_directory_uri() . '/fonts/css/font-awesome.min.css', array(), '1.0', true ); } add_action( 'wp_enqueue_scripts', 'theme_name_script_enqueue' ); 

Ich hatte …

 function theme_name_script_enqueue() { wp_enqueue_style( 'wpb-fa', get_template_directory_uri() . '/fonts/css/font-awesome.min.css' ); } add_action( 'wp_enqueue_scripts', 'theme_name_script_enqueue' ); 

Beachten Sie, dass ich fehlte , array(), '1.0', true

Sobald das obige eingefügt wurde, funktionierte alles einwandfrei.