Warum bekomme ich dieses merkwürdige Verhalten von WP_Query, wenn ich versuche, Beiträge mit einem bestimmten Tag auszuwählen?

Ich habe das folgende Problem mit vorgestellten Tag-Posts

Ich habe eine Seite einer Website, auf der ich nur die Posts anzeigen möchte, die ein bestimmtes Tag gesetzt haben (mit der Schleife).

Also auf dieser Seite habe ich diesen Loop-Code gesetzt:

<?php echo"

IN EVIDENZA:

"; $featured = new WP_Query('tag=featured'); if ($featured->have_posts()) : while ($featured->have_posts()) : $featured->the_post(); /* * Include the post format-specific template for the content. If you want to * use this in a child theme, then include a file called called content-___.php * (where ___ is the post format) and that will be used instead. */ get_template_part('content', get_post_format()); endwhile; //wp_reset_postdata(); else : // If no content, include the "No posts found" template. get_template_part('content', 'none'); endif; ?>

Theoretisch sollte dieser Loop nur den Post zeigen, der den Tag mit dem Feature Tag hat, aber er funktioniert teilweise, weil er alle Posts anzeigt, die den Tag haben, aber wenn es einen einzigen Post gibt, zeigt es auch, wenn dieser Post nicht das Feature hat Tag gesetzt.

Ich kann nicht verstehen, warum es passiert, weil ich festlege, dass nur das vorgestellte Tag durch diese Abfrage ausgewählt werden muss:

 $featured = new WP_Query('tag=featured'); 

Was vermisse ich? Wie kann ich dieses Problem lösen?

Tnx

Solutions Collecting From Web of "Warum bekomme ich dieses merkwürdige Verhalten von WP_Query, wenn ich versuche, Beiträge mit einem bestimmten Tag auszuwählen?"