undefinierte function apache_request_headers ()

Ich versuche, den folgenden Befehl lokal auszuführen:

/usr/local/bin/wp plugin deactivate "EG Fulltext Search" --allow-root 

Und ich bekomme den Fehler undefined function apache_request_headers()

Hier ist die wp info:

 PHP binary: /usr/bin/php PHP version: 5.5.37 php.ini used: /etc/php.ini WP-CLI root dir: phar://wp-cli.phar WP-CLI packages dir: WP-CLI global config: WP-CLI project config: WP-CLI version: 0.24.0-alpha-95a84de 

Dies läuft Apache auf Centos 7. PHP läuft als Apache 2.0 Handler.

Ich benutze die nächtliche Version, aber ich bekomme auch diesen Fehler die letzte stabile Version.

Ich bin im Moment wirklich daran fest und kann die wp-Befehle nicht verwenden, so dass jede Hilfe wirklich geschätzt würde.

Solutions Collecting From Web of "undefinierte function apache_request_headers ()"

Von der Schnellsuche kann ich keine Aufrufe dieser function in WP-core oder WP-CLI finden.

Nach einer kurzen Überprüfung der Dokumentation scheint es, dass die Unterstützung dafür im CLI-Kontext (relativ) neu ist – beginnend mit PHP 5.5.7.

Vielleicht möchten Sie überprüfen, ob Ihr PHP auf dem neuesten Stand ist. Beachten Sie, dass auf CLI möglicherweise eine andere / ältere PHP-Version vom Webserver ausgeführt wird.