Tabs für das WordPress-Plugin verwenden

Ich habe meine Nachforschungen gemacht und herausgefunden, dass ich das eingebaute jQuery-Skript für ui tabs in wp für den Admin-Bereich aufrufen kann, aber ich stecke bei der Implementierung der anderen benötigten jquery-Skripte fest, von denen ich glaube, dass sie in wp integriert sind. Ich weiß, wie man das css hinzufügt und gerade html hinzufügte, ich will nur keine Probleme mit anderen vorhandenen Plugins verursachen, also möchte ich diese Skripte unten richtig hinzufügen, die erforderlich sind.

http://code.jquery.com/jquery-1.8.3.js

http://code.jquery.com/ui/1.9.2/jquery-ui.js

Hier ist, was ich für Javascript verwenden werde (wieder wie Sie die obigen Skripte hinzufügen?):

function my_plugin_load_js() { wp_enqueue_script('jquery-ui-tabs'); } add_action('admin_enqueue_scripts', 'my_plugin_load_js' ); function mypluginjs() { echo ' jQuery(function() { jQuery( "#tabs" ).tabs(); }); '; } add_action( 'admin_enqueue_scripts', 'mypluginjs' ); 

Hier ist, was ich bisher für HTML bekommen habe:

 

My plugin

options tr/td go here
options tr/td go here
options tr/td go here

<input type="submit" class="button-primary" value="" />

Solutions Collecting From Web of "Tabs für das WordPress-Plugin verwenden"

Wenn es nur ein Problem mit HTML-Markup gibt, sollten Sie das Beispiel von der offiziellen jQuery UI-Site hier überprüfen: http://jqueryui.com/tabs/

Es sieht wie Ihres aus, aber für die Arbeit müssen Sie überprüfen, ob Ihre Site Sachen wie jquery und jquery ui enthält, jquery css ist auch wichtig. Danach solltest du ein Skript haben mit:

 $( "#tabs" ).tabs(); 

Und alles sollte gut funktionieren. Wenn Sie denken, dass alles in Ordnung ist mit Setup und Sie keine Ergebnisse sehen, sollten Sie Ihre Browser-Konsole für weitere Informationen über Fehler von Javascript-Engine überprüfen.