Seltsame ‘Theme Update’ Fehler

Ich entwickle ein Thema (das ich AsylumInfo nenne), das in ein Verzeichnis Call /build eingebaut wird und ich habe Symlink von dort zum WordPress-Setup auf meinem Computer.

Wenn ich wp-admin verwende, erhalte ich die Benachrichtigung unten. Wenn ich auf die Themen-Auswahlseite gehe und auf “Thema aktualisieren” klicke, sehe ich Folgendes.

Error

Wenn ich auf den Link View version 1.13 klicke, werde ich zu https://wordpress.org/themes/build/ weitergeleitet . Mit anderen Worten, WordPress scheint den Namen des Verzeichnisses zu sehen, nicht den Namen des Themas, bevor er versucht, online ein nicht existierendes Update zu finden. Durch das private Thema gibt es überhaupt keine Verbindung zu diesem veröffentlichten Thema und ich möchte, dass WordPress nicht mehr daran denkt, dass ich upgraden muss .

Wie kann ich das loswerden? Ich stelle mir vor, eine Option ist das Umbenennen /build zu /asyluminfo , was ich tun kann, aber nicht notwendig sein kann. Ein anderes ist die Version meines Themes auf etwas> 1,13, aber das ist auch willkürlich.

Ich kann nicht glauben, dass das vorher niemandem passiert ist?

Solutions Collecting From Web of "Seltsame ‘Theme Update’ Fehler"

Für den Detail-Link müssen Sie Details URI: festlegen Details URI: in der Kopfzeile der style.css Ihres style.css

Dein Theme Name: Auch dort sollte der Slug erstellt werden, mit dem WordPress das wordpress.org Theme Repository nach Updates über die Update API abfragt. (Ich weiß sicher, dass ich getestet habe, dass Slugs für Plugins aus dem Namen des Plugins erstellt werden, ich denke, dass es für Themen dasselbe sein wird, aber ich habe es nicht speziell getestet.)