Probleme beim Umleiten auf “schöne” Permalinks (WordPress in Subdirectory)

Ich habe Probleme, schöne Permalinks zum Arbeiten zu bekommen.

Wenn ich die Permalinks ändere (zB zu Monat / Name), wird meine .htaccess (im WordPress-Verzeichnis – es gibt noch eine weitere Ebene) so geändert:

AddType x-mapp-php5 .php AddHandler x-mapp-php5 .php # BEGIN WordPress  RewriteEngine On RewriteBase /wordpress/ RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /wordpress/index.php [L]  # END WordPress 

Aber ich bekomme immer noch 404s, wenn ich versuche auf eine existierende Seite zuzugreifen.

Mein Blog ist im Unterverzeichnis / wordpress /, nicht sicher, ob das ein Problem sein könnte. Die URLs sind beide auf http:///wordpress , wo sich meine WordPress-Dateien befinden.

Irgendwelche Ideen, was ich tun kann, wo ich die Ergebnisse der Überarbeitung oder irgendetwas anderes sehen kann, das mir helfen würde, das Problem aufzuspüren?

Danke im Voraus!

Solutions Collecting From Web of "Probleme beim Umleiten auf “schöne” Permalinks (WordPress in Subdirectory)"

Speichern Sie Ihre bestehende .htaccess Datei, indem Sie sie in backup.htaccess und speichern Sie Ihre Permalinks erneut, um eine neue .htaccess Datei zu erstellen. Das triggers die meiste Zeit Probleme.

Ich habe es endlich geschafft, die Ursache des Problems zu finden. Es war ein Plugin, das Probleme zu haben scheint (Top Level Categories). Ich habe mir ihre Dokumentation angesehen, aber es gibt keinen Hinweis darauf, dass ich auf dieses Problem stoßen würde. Hmmmm …

Zumindest funktioniert es jetzt!