Post / Page Publish / Update Button kann nicht angeklickt werden, sobald ich eine Änderung vorgenommen habe

Ich öffne eine Seite und führe eine Bearbeitung durch und der Update-Button wird ausgegraut. Ich muss den gesamten Seiteninhalt kopieren, die Seite aktualisieren und wieder auf der Seite einfügen, erst dann wird der Update-Button anklickbar. Es aktualisiert die Seite, so dass es kein Problem damit gibt.

Nur wenn die anfängliche Bearbeitung gemacht wird, ist nicht anklickbar.

Update: Ich konnte das Problem neu erstellen, aber nicht treu . Es scheint zu auftreten, wenn die Seite versucht, automatisch zu speichern. Es würde automatisch speichern und dann hängen.

Ich weiß nicht einmal, wo ich anfangen soll. Ist jemand auf etwas Ähnliches gestoßen?

Solutions Collecting From Web of "Post / Page Publish / Update Button kann nicht angeklickt werden, sobald ich eine Änderung vorgenommen habe"

Es scheint sich um einen Fehler zu handeln, der jedoch jedes Mal, wenn es mit ungefähr 2 Sekunden Arbeit passiert, gehackt werden kann. Dieser WordPress-Forum-Thread :

Wenn Sie Chrome verwenden, klicken Sie mit der rechten Maustaste auf die ausgegraute Schaltfläche “Aktualisieren” und wählen Sie “Element prüfen”. Sie werden etwas sehen wie:

Löschen Sie einfach das Wort disabled und der Update-Button wird wieder anklickbar. Klicken Sie darauf und es sollte aktualisiert werden.

Rettete mich beim Nachladen und Verlieren von Arbeit.

Siehe auch diesen weniger aufgetriggersen Thread .

Nachdem ich festgestellt hatte, dass es sich um ein Problem mit der automatischen Speicherung von Seiten / Post handelte und nicht um das Einfügen von Daten aus einem Texteditor, deaktivierte ich alle Plugins, um festzustellen, ob dies der Grund war. Das Deaktivieren der Plugins scheint keine Auswirkungen zu haben.

In der Browsererrorskonsole wurden keine Fehler gemeldet.

Ich habe die WordPress-Installation manuell aktualisiert und dies scheint das Problem behoben zu haben. Leider verstehe ich nicht warum, keine der ersetzten Dateien wurde jemals von mir bearbeitet.

Ich habe eine function im save_post-Hook via registriert

 add_action('save_post', 'my_function', 10, 3); 

In der function selbst habe ich nichts gemacht außer der Protokollierung zu Testzwecken, und die Schaltfläche wurde nach dem automatischen Speichern (und meine function wurde ausgetriggers) immer noch deaktiviert.

Meine function wurde nach den Logs auch peridodisch ~ 20-30s genannt.

Ich habe meine function abgemeldet und der Button hat wieder einwandfrei funktioniert.

Es stellte sich heraus, dass die Protokollierung in error_log / syslog selbst das Problem war. Als ich meine benutzerdefinierte Protokollfunktion deaktivierte, funktionierten mein Code und die registrierte function, und die Schaltfläche wurde nie wieder deaktiviert.