<? PHP wird in <! -? PHP geändert

Wenn ich ein PHP-Code-Snippet in einen WordPress-Post poste, wird es konvertiert

<?PHP in <!--?PHP

Um dies zu vermeiden, muss ich <?PHP durch <?PHP ersetzen

Ich frage, ob es eine Einstellung oder eine einfache Methode gibt, dies zu vermeiden? Wenn nicht, denke ich daran, vielleicht eine PHP-function zu schreiben, die den Inhalt filtert und <?PHP mit <?PHP

Irgendwelche Ideen

Solutions Collecting From Web of "<? PHP wird in <! -? PHP geändert"

PHP wird als Sicherheitsfeature aus dem WordPress-Posteditor herausgefiltert. Es gibt einige Plugins, mit denen man sie einfügen kann, aber ich denke, dass sie eine ziemlich schlechte Idee sind, also werde ich nicht einmal auf sie verlinken.

Wenn Sie PHP auf einer Seite benötigen, sollten Sie diesen Code in eine Vorlagendatei oder in functions.php oder eine Plug-in-Datei einfügen, die an einer Seite hängt, die Sie ändern möchten.

Hier ist meine einzige Idee so weit

 function strip_php($content) { return str_ireplace("< ?PHP", "<?PHP", $content ); } add_filter('content_save_pre','strip_php');