leeres WP_Query-Objekt bei lokaler Installation

Ich habe gerade festgestellt, dass ich ein komplettes * leeres WP_Query-Objekt * auf meiner WordPress-Installation hatte. Ich habe die DB zurückgesetzt, alle Plugins deaktiviert und TwentyTen als Theme aktiviert, aber das komplette Objekt ist bei jeder Anfrage leer (public & admin). Es ist egal, ob ich den ” Hallo Welt ” -Post oder einen 404 anfordere. Alles ist leer. Welchen Grund könnte das haben?

Bearbeiten 1
So überprüfe ich WP_Query :

 // inserted on top of the functions.php file, // so it's equal to a function hooked into the 'after_setup_theme' hook // i also tried other hooks (which should make no difference) and got the same result. echo '
'; print_r($GLOBALS['wp_query']); echo '

';

Dies ist das Ergebnis von print_r();

 WP_Query Object ( [query] => [query_vars] => Array ( ) [tax_query] => [queried_object] => [queried_object_id] => [request] => [posts] => [post_count] => 0 [current_post] => -1 [in_the_loop] => [post] => [comments] => [comment_count] => 0 [current_comment] => -1 [comment] => [found_posts] => 0 [max_num_pages] => 0 [max_num_comment_pages] => 0 [is_single] => [is_preview] => [is_page] => [is_archive] => [is_date] => [is_year] => [is_month] => [is_day] => [is_time] => [is_author] => [is_category] => [is_tag] => [is_tax] => [is_search] => [is_feed] => [is_comment_feed] => [is_trackback] => [is_home] => [is_404] => [is_comments_popup] => [is_paged] => [is_admin] => [is_attachment] => [is_singular] => [is_robots] => [is_posts_page] => [is_post_type_archive] => [parsed_tax_query] => ) 

Solutions Collecting From Web of "leeres WP_Query-Objekt bei lokaler Installation"