Ich habe Probleme mit previous_post_link () und next_post_link ()

Ich habe in letzter Zeit eine WordPress-Seite entwickelt und bin auf ein Problem gestoßen. Ich brauche den Benutzer, um zwischen Posts zu navigieren, ich benutze die WordPress-Standardfunktionen previous_post_link() und next_post_link() die in THEORY die Links zu den nächsten und vorherigen Posts in der database ausgeben sollen … ABER die einzigen Links diese erscheinen im Fall des letzten Posts; der erste Post, der veröffentlicht wurde und im Fall des ersten Posts, der veröffentlicht wurde; der neueste Beitrag

Es gibt 5 Posts und alle produzieren die gleichen Links, ich mache nichts albern oder außerhalb der Box.

Ich hatte auch einige anfängliche Probleme mit der Paginierung im Hauptblogfeed, aber das scheint jetzt behoben zu sein ….

Hier ist mein Code:

single.php

  

BLOG

<img class="single__image" src="https://wordpress.stackexchange.com/questions/158652/im-having-some-issues-with-previous-post-link-and-next-post-link/ID))); ?>">

Posted on by

und hier ist der Haupt-Blog-Feed:

index.php

   

BLOG

<img class="blog__image" src="https://wordpress.stackexchange.com/questions/158652/im-having-some-issues-with-previous-post-link-and-next-post-link/ID))); ?>">

<a href="https://wordpress.stackexchange.com/questions/158652/im-having-some-issues-with-previous-post-link-and-next-post-link/">

<a class="blog__post__more" href="https://wordpress.stackexchange.com/questions/158652/im-having-some-issues-with-previous-post-link-and-next-post-link/">Continue Reading

There are no posts to display at this time.

Ich hoffe, dass jemand mir bei diesem Problem helfen kann, wenn Sie mich zu möglichen Korrekturen führen können, die großartig wären! Obwohl ich bereits gesucht und gesucht habe, versuchte Leute Vorschläge usw., weshalb ich diesen Beitrag gemacht habe.

Wenn etwas nicht klar ist, lass es mich wissen 🙂

Danke im Voraus!

Solutions Collecting From Web of "Ich habe Probleme mit previous_post_link () und next_post_link ()"

Ich habe erkannt, was das Problem war … einige meiner Posts wurden (für Entwicklungszwecke) mit Hilfe von Bulk Creator erstellt, der scheinbar keinen vollständigen Post erstellt! Wenn ich einen Post manuell über das WP-Backend erstelle, funktioniert mein Code gut, danke für die Vorschläge, Jungs!