get_option () ist in TinymceWindowManager nicht definiert

Ich habe Button zu Tinymce Editor hinzugefügt, der Popup mit TinyMCE Window Manager öffnet und Popup-Datei ist sbb-pop.php.

Ich möchte die Einstellungen mit get_option () im Popup-Fenster anzeigen. Aber es wirft einen Fehler auf get_option () ist nicht definiert .

Unten ist Code in sbb-popup.php

$apikey = get_option('sbb_api_key_value'); $api_link = 'https://1securecart.net/Maint/CatalogItem/GetCatalogItems?APIKey='.$apikey; $content=file_get_contents($api_link); $data=json_decode($content); 

Hier ist JS um Button hinzuzufügen und Popup zu zeigen.

 (function($) { tinymce.PluginManager.add('sbb_mce_btn', function( editor, url ) { editor.addButton( 'sbb_mce_btn', { id:'sbb-btn', text: 'SBB', icon: false, type: 'menubutton', onclick:function(){ editor.windowManager.open({ url:sbbGlobalVars.sbbPluginDir+"sbb-popup.php", width:500, height:250 }, {plugin_url:url, }); } }); }); })(); 

Gibt es eine andere Möglichkeit, Optionen im Popup-Fenster zu laden? Ich kann wp-load.php nicht nach WordPress-Standard aufnehmen.

Solutions Collecting From Web of "get_option () ist in TinymceWindowManager nicht definiert"