Die Alert-function konnte nicht mit dem Backend-Widget mit dem neuesten WP konsistent arbeiten

Ich habe ein Back-End-Widget, das ich als Teil eines WordPress-Plugins entwickelt habe. Die Alarmfelder funktionieren jedoch überhaupt nicht und ich bin verwirrt warum. Dies ist eine Standardinstallation des neuesten WP mit dem Standarddesign, das mit einer neuen Installation geliefert wird. Mein Widget befindet sich unter:

http://codesupport.shalomisrael.org/wp-content/plugins/carousel_edit_url_for_newspro_201709181655.zip

Bitte helfen Sie!

Debugging-Schritte:

1) Begann mit einer Neuinstallation der neuesten Version von WordPress mit GoDaddy Shared Hosting und geladen nur das eine Plugin => Problem besteht, dass die Alarmfelder nicht die erwarteten Werte zeigen. 2) Habe einen Beispielcode von w3schools.com gefunden, der sich auf simpletest.com in der Haupt-Web-Domain befindet. Ich kann nur 2 Links mit meinem aktuellen Status aufnehmen. 3) Hat einen Screenshot des Problems gemacht. Grundsätzlich wird der Wert nicht korrekt wie folgt aufgezeichnet:

[Screenshot des Drop-Down-Problems funktioniert nicht] http://img.daswordpress.com/widgets/DropDownBugScreenShot201709191216.jpg

Solutions Collecting From Web of "Die Alert-function konnte nicht mit dem Backend-Widget mit dem neuesten WP konsistent arbeiten"

Ich habe den Namen der Backend-Widget-Referenz auf “carousel_edit_url_for_newspro / backendwnisoform.php” geändert, um das Problem auf das Wesentliche zu beschränken.

Der Code unten funktioniert, loben G-tt. Ich sollte dann in der Lage sein, diese Art von Code im Hauptstrom der Programmentwicklung zu verwenden, damit die Drop-down-Menüs gut funktionieren, G-tt-willig:

?>

Hi There!

Für diejenigen, die das neueste Skript, das richtig funktioniert (nur für dieses eine Problem isoliert), ist es verfügbar von:

Zip-Datei mit dem Plugin mit dem einen Element funktioniert gut