Das Multisite-Domain-Mapping unterbricht CSS

Ich habe eine Multisite (Unterverzeichnisse) eingerichtet und alle meine Plugins / CSS funktionierten einwandfrei. Dann fügte ich die Domänenzuordnung hinzu und verwaltete eine Domain example.com auf eine Site-ID 4. Alles funktioniert immer noch gut.

Wenn ich jedoch example.com für die Site-ID 4 “primary” verwende, scheint das CSS zu brechen. Meine Plugins (zB Responsive Slider) funktionieren nicht mehr, mein CSS auch. In dem Moment, in dem ich das “primäre” nicht mehr überprüfe, scheint alles in Ordnung zu sein.

Irgendwelche Ideen, was passieren könnte?

Solutions Collecting From Web of "Das Multisite-Domain-Mapping unterbricht CSS"

Das ist eine alte Frage, aber ich bin gerade auf dasselbe Problem gestoßen und habe das Problem gefunden: Das Plugin MU Domain Mapping verwendet eine veraltete Konstante, PLUGINDIR, um die Plugin-Verzeichnisse auf den zugeordneten Domains neu zuzuordnen.

Das Plugin scheint heutzutage sehr vage entwickelt zu sein (und seit einem Jahr gibt es keine Veröffentlichungen mehr), also habe ich meine Kopie des Plugins direkt bearbeitet. domain_mapping.php in domain_mapping.php für die function domain_mapping_plugins_uri() (um Zeile 650) diese function, indem Sie einfach $full_url ohne die anderen Routinen zu durchlaufen.

Dies sollte das Problem beheben.

Sehen Sie sich diese Anleitung an, Debuggen eines WordPress-Netzwerks . Diese Art von Problem wird normalerweise durch einen Konfigurationserrors in der .htaccess-Datei verursacht. Überprüfen Sie auch diese Seite, die Multisite-Konfiguration schlägt mit css / js-Dateien fehl