Das JSON-API-Plugin zeigt die Anlagen-ID nicht erneut an

Vor allem spreche ich über dieses Plugin: https://wordpress.org/plugins/json-api/

Also jetzt zu meinem Problem: Das Plugin funktioniert einwandfrei und ohne Probleme. Alle Anhänge werden für alle Beiträge angezeigt, aber mein Problem beginnt, wenn ich einen Anhang für den Beitrag erhalten möchte und der Anhang früher in einem anderen Beitrag verwendet wurde. In diesem Fall gibt es null zurück (kein Attachement oder nicht das wiederverwendete).

Also um klar zu sein:

Post A Image A --> shows Post B Image A --> doesn't shows 

Warum passiert das und wie kann man das beheben? Danke für jede Hilfe!

Solutions Collecting From Web of "Das JSON-API-Plugin zeigt die Anlagen-ID nicht erneut an"

Es gibt also mehrere Möglichkeiten, wie Bilder mit dem Post “verwandt” werden können:

  1. Wenn Sie ein Bild im Postkontext hochladen, wird der Beitrag als sein übergeordnetes Element festgelegt (dh das übergeordnete Feld mit Bildanhängen enthält die ID des Beitrags).
  2. Wenn Sie das Bild als Feature auf einem Post festlegen (oder ähnliche functionalität aus benutzerdefinierten Feld-Frameworks verwenden), zeichnet der Post die ID des Bildanhangs in seinem Meta auf.
  3. Wenn Sie ein Bild in den Post-Inhalt einfügen, werden die Details des Posts des Bildanhangs zur Erstellung des Markups verwendet.

Von diesen ist der dritte der schwächste Code. Wenn der einzige etablierte Link das HTML-Markup mit der URL zum Bild ist, dann ist es schwierig, es auszuwerten und in sinnvolle ID umzukehren. Nicht unmöglich, aber es ist ein Durcheinander.

Wenn Sie einen bestimmten Anwendungsfall haben, z. B. ein einzelnes Bild, das mit dem Post zu einem bestimmten Zweck verknüpft ist, sollten Sie vordefinierte Grafiken oder einen ähnlichen Ansatz verwenden, um mit IDs zu arbeiten.