Benutzerdefinierter Beitragstyp-Kategoriepost wird nicht angezeigt

Also habe ich die folgende CPT / Taxonomie Einstellung in meinen functionen und ich habe die Permalink Struktur wie: /%category%/%postname%/

Meine www.dn.com/photography/category/ sehen etwas wie www.dn.com/photography/category/ was gut ist, aber Beiträge, die unter der Kategorie sind, www.dn.com/photography/category/ nicht auf.

So eine URL wie www.dn.com/photography/category/post zeigt auch nicht www.dn.com/photography/post .

Idealerweise hätte ich die URL wie www.dn.com/photography/category/post aber ich bin mir nicht sicher, wo ich falsch www.dn.com/photography/category/post ?

Meine CPT / Taxonomie functionen:

   array( 'name' => __( 'Photography', 'dn' ), 'singular_name' => __( 'Photography Post', 'dn' ), 'all_items' => __( 'All Photography Posts', 'dn' ), 'add_new' => __( 'Add New', 'dn' ), 'add_new_item' => __( 'Add New Photography Post', 'dn' ), 'edit' => __( 'Edit', 'dn' ), 'edit_item' => __( 'Edit Post', 'dn' ), 'new_item' => __( 'New Post', 'dn' ), 'view_item' => __( 'View Post', 'dn' ), 'search_items' => __( 'Search Posts', 'dn' ), 'not_found' => __( 'Nothing found in the Database.', 'dn' ), 'not_found_in_trash' => __( 'Nothing found in Trash', 'dn' ), 'parent_item_colon' => '' ), /* end of arrays */ 'description' => __( 'This is the Photography section.', 'dn' ), 'public' => true, 'publicly_queryable' => true, 'exclude_from_search' => false, 'show_ui' => true, 'query_var' => true, 'menu_position' => 6, 'menu_icon' => 'dashicons-camera', 'rewrite' => array( 'slug' => 'photography', 'with_front' => false ), 'has_archive' => true, 'capability_type' => 'post', 'hierarchical' => true, 'supports' => array( 'title', 'author', 'thumbnail', 'sticky') ) /* end of options */ ); /* end of register post type */ } add_action( 'init', 'custom_post_example'); // Add custom categories register_taxonomy( 'photography_cat', array('photography'), array('hierarchical' => true, 'labels' => array( 'name' => __( 'Photography Categories', 'dn' ), 'singular_name' => __( 'Photography Category', 'dn' ), 'search_items' => __( 'Search Photography Categories', 'dn' ), 'all_items' => __( 'All Photography Categories', 'dn' ), 'parent_item' => __( 'Parent Photography Category', 'dn' ), 'parent_item_colon' => __( 'Parent Photography Category:', 'dn' ), 'edit_item' => __( 'Edit Photography Category', 'dn' ), 'update_item' => __( 'Update Photography Category', 'dn' ), 'add_new_item' => __( 'Add New Photography Category', 'dn' ), 'new_item_name' => __( 'New Photography Category Name', 'dn' ) ), 'show_ui' => true, 'show_admin_column' => true, 'query_var' => true, 'rewrite' => array( 'slug' => 'photography' ), ) ); ?> 

Solutions Collecting From Web of "Benutzerdefinierter Beitragstyp-Kategoriepost wird nicht angezeigt"