Azure WordPress-Site – URLs, die beim Verschieben vom Stammverzeichnis in das Unterverzeichnis nicht angezeigt werden

Verschieben Sie die Site vom Stammverzeichnis in ein Unterverzeichnis, indem Sie den folgenden statementen folgen: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  • Die WordPress-Site-URL und die Site-URL wurden geändert (in diesem Fall das gleiche)
  • Unterverzeichnis erstellt
  • Bearbeitete die index.php
  • Kopierte alle Dateien in das Unterverzeichnis (außer web.config)
  • Die Datei “web.config” wurde in das Unterverzeichnis verschoben
  • Überprüft die Permalinks

Ich kann mich in wp-admin einloggen, aber nicht auf den Seiten werden Inhalte angezeigt – nur leere Seite.

Dies ist das erste Mal mit Azure – bitte entschuldige meine Unwissenheit.

Shelleyjane

Solutions Collecting From Web of "Azure WordPress-Site – URLs, die beim Verschieben vom Stammverzeichnis in das Unterverzeichnis nicht angezeigt werden"

Laut dem Beitrag, den Sie angegeben haben, wenn Sie dem Abschnitt Verschieben einer Root-Installation in ein eigenes Verzeichnis folgen, scheint es, dass das WordPress-Dashboard-Panel über die Besuchs-URL wie "http://example.com//..." und WordPress-Frontend-Site über "http://example.com" .

Wenn dies Ihre Anforderung ist, scheint es, dass es einige verschiedene Schritte mit meinem Test gibt und was auf meiner Seite gut funktioniert. Sie können meine Einstellungen versuchen:

  • Die WordPress-Site-URL wurde in "http://.azurewebsites.net/"
  • Ändern Sie nicht die Site-Adresse (URL) (behalten Sie "http://.azurewebsites.net" )
  • Verschieben Sie Ihre WordPress-coredateien in den Unterordner außer web.config .
  • create index.php im root-Verzeichnis (außerhalb des Unterordners) mit contain: define('WP_USE_THEMES', true); require( dirname( __FILE__ ) . '/wordpress/wp-blog-header.php' ); define('WP_USE_THEMES', true); require( dirname( __FILE__ ) . '/wordpress/wp-blog-header.php' );
  • Überprüfen Sie die Permalinks

Hier ist die endgültige Struktur meiner Azure Web App:

Bildbeschreibung hier eingeben

Jede Sorge, bitte zögern Sie nicht mich wissen zu lassen.

Danke für die schnelle Antwort. Ich habe den Umzug erfolgreich in das Unterverzeichnis abgeschlossen. Ich denke, weil ich die coredateien in das Unterverzeichnis “kopiert” habe, anstatt sie zu “verschieben”, war mein Fehler. Ich musste die index.php in den root kopieren und dann die Details ändern, anstatt eine neue index.php zu erstellen. Danke noch einmal.